Follow

Upgrading iOS 1.2.1 to 1.3.1

Before starting please follow 'Upgrading your project' guide to ensure you have the latest v1.3.1 iOS installed on your machine, as well as a recent back up your code, then follow the process to update an existing Xcode projects Pugpig framework files. We recommend using Xcode to 6.0+.

Once complete carry out the following steps to upgrade from version 1.2.1 to 1.3.0 or 1.3.1 of Pugpig for Continuous Publishing:

  1. Set the UIViewControllerBasedStatusBarAppearance Info.plist key to YES. If this key is missing from you Info.plist file, please add it and set it to YES
  2. You need to remove the new line characters ("\n") from the following strings in your project's "localizable.strings" and "localizable.stringsdict" files:
    1. "pugpig_relative_date_now"
    2. "pugpig_relative_date_today"
    3. "pugpig_relative_date_on_date"
    4. "pugpig_relative_date_days"
    5. "pugpig_relative_date_minutes"
  3. You need to create a new project and extract the down-arrow asset, or provide your own down arrow asset for the pull to refresh functionality.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk